Fanatec Driver 439 (Public Release) (435-437 before) for CSL, CSW and Podium WB (all wheels)



  • So about to update driver 435 to 437.

    With a DD2 is there also still a test firmware for the wheel to use? Or is it incorporated in 437?


    1. Will this be fixed?
    2. To me, this is far from intuitive, but that's just me.
  • in version 437 is the problem solved that the steering wheel could turn in one direction when you go into the game menu? i have a problem with my wrist and don't want to risk pain if the steering wheel does something i don't anticipate

  • With 437, the right analog paddle on the McLaren GT3 v2 doesn't work, it's stuck on 100%, tried reflashing firmware and switching center dial modes but nothing changes. I didn't have this problem in 436 or earlier.

    Can you please map two physical buttons to buttons 7 & 8. It's challenging missing such fundamental buttons that some games don't allow you to remap like the entire F1 series. The McLaren GT3 is the only wheel that's not compatible with F1 2021 (and I believe prior F1 versions don't work with this wheel either) If you have no plans to make this work, could you at least acknowledge that the firmware on this wheel is broken and you don't intent to fix? all the forum posts asking about this have been ignored since the wheel launched.

  • edited February 2022

    I agree with Adam,

    Dd2 latest drivers and firmware and fanalab.

    Rfactor 2: driver 415, FFB in rFactor 2 felt a lot better around centre, you could feel tire grip through FFB, allowing you to feel the understeer and oversteer. Now the wheel is loose and then becomes notchy when the FFB builds up.

    I have applied the recommended settings in the driver/fanalab and in game.

    RF2 just undeliverable at the moment with the lastest drivers.

    Other games like ACC, AMS2 and DIRT 2 feel fine, it's just RF2 FFB thats become worse.

    Mates have other DD's from other brands and not experiencing these issues in RF2.

    Please fix the RF2 FFB in the drivers, or provide new recommend settings to fix these issues.

  • yep back again with 437

    flashed the base FW and still ok

    still no show in the fanalab but thats a different forum/thread :)


  • For my GT DD PRO with V3 Pedals, 1.5 Shifter, Handbrake:

    I had been running 434 with a "CSL_DD_Base_V1_1_5_2_testExport_reva059d384_app_S (1)" hex file I got from support that had worked pretty good for maybe 4 hours of driving. No miss shifts. No Flicker

    So I saw here there was a new version and tried the Beta driver with the "V1_1_5_4_etc..." Hex file and I have had lots of miss shifts again.

    Most common miss shifts are 2nd instead of 4th, 1st instead of 4th and 4th instead of 6th. So it seems to always be the bottom row of gears.

  • why don't you just go back to the old hex file for now...

  • Hi Maurice,

    Thanks for your prompt response.

    Is it Disable NFR or DPR?

    I have read cases for either in this thread.

    Also, what controls the soft lock in the driver software?

    Is it just the degrees of rotation in fanalab or is there an option in the driver somewhere for it to lock at that maximum rotation?

    It appears to not be working with the latest drivers in RF2.

    Thanks again.

  • Leon van HeesLeon van Hees Member
    edited February 2022
    1. Which driver OR firmware shows the issue - 436 AND 437
    2. Post the answers gathered from the questions above + a short description of the issue including the following info:
    • Wheel Base Model (product ID): CSL Elite
    • Steering Wheel Model (product ID): BMW GT2 V1
    • Driver Version: 437
    • Base FW Version: 467
    • Motor FW Version: 18
    • Driver/FanaLab installed on C: drive or else? - YES
    • With driver related issues collect log files and zip them from C:\Users\Public\Fanatec Logs

    I want to update the firmware of my components.


    1 - Downloaded driver 436 (and the 437 beta after that) from the Fanatec Website, installed it and restarted my PC.

    2 - Started the Fanatec control panel as Admin


    3 - Attached the setup via the original Fanatec USB cable to the rear of the PC, plugged in the power and set the wheelbase to PC mode (red LED).

    All items get recognized and the "New Firmware Available" notice is displayed.

    4 - Open Firmware manager

    5 - Select Update, pop up window with timer appears.

    6 - Click OK on timer window

    At this point I have tried several things, all to no avail

    - wait, for an hour

    - Click the Green "update" button

    - close the application, repeat everything up to step 4, select "manual update"

    None of these steps result in updated firmware.

    I searched on Reddit, found people with similar issues, but most were pre-firmware manager, with the previous control panel. Tried some suggestions, like:

    - Unplug everything from the wheelbase, including the steering wheel

    - Use different USB cable

    - Turn off windows defender, and/ or any other firewall blocking software.

    - Turn off virus scanner

    None of this worked, I even tried all of this on my laptop, just to rule out my PC, so I am hoping that you have any suggestions. The hardware works fine, I would just like to have the latest and greatest firmware on it.

  • edited February 2022

    Could be both NFR and DPR but there is also an issue in iRacing where DPR gets activated by the game after a big Crash for no reason so I would definitely try rf2 with DPR off as well to test if it's fixed.

    Soft lock needs to be supported by the game, SEN in the Tuning Menu has to be set to AUTO but I think rf2 does not support that feature.

  • Sorry for late feedback, have been busy lately. I'm currently running the 437 with the dd1 motor testfw (nfr fix) and just wanted to confirm that the NFR feels much better now in f1.

  • I am getting the "exceeded maximum rotation" bug on my current DD1 podium wheelbase. This update shows this has been fixed, but then it is also crossed. What does this supposed to mean? You tried to fix it but got reports back that it didn't, or the fix didn't make into this beta, or it is not fixed properly yet but will be in the final release?

    Thank you

    • Fixed error message of "exceeded maximum rotation" getting shown without reason

  • Wheel Base Model (product ID): Podium Wheel Base DD1 (P_WB_DD1_EU)

    Steering Wheel Model (product ID): Clubsport Steering Wheel Universal Hub for Xbox One (CSW_RUHX)

    Driver version: 437

    Base FW version: 691

    Engine FW version: 42

    FanaLab Version: Not installed!

    Driver/FanaLab installed on C: !

    Windows 11 Pro, Ver. 21H2, Build: 22000.493

    Raceroom feels good after the first round, then everything becomes a bit sluggish, the in-game FFB graph shows no change, although something has changed. At the beginning I had increased the FFB multiplier of the vehicle because it felt weaker at first, now it's just stiffer and without details, as if there was hardly any air left in the tires.

    To try out the new feature of R3E, I selected Auto in the tuning menu, but nothing is changed by the game, it stays at the Fanatec defaults. I recognized this on the DD1 display, when I was scrolling through the last value, the DD1 freezes and I have to disconnect it from the power supply because the on/off button no longer works either.

    SEN = Auto, FFB = 70%, FFS = Peak, NDP = Off, NFR = Off, NIN = Off, INT = 1, FEI = 100%, FOR = 100%, SPR = 100%, DPR = 100%


    ACC feels good after a short test, no difference if I change NFR from 2 to 0.

    SEN = 1080, FFB = 50%, FFS = Peak, NDP = Off, NFR = Off (or 2), NIN = 3, INT = 2, FEI = 100%, FOR = 100%, SPR = 100%, DPR = 100%


    Dirt Rally with NFR on 3 after a short time again shows the problem that the steering becomes stiff. With NFR set to 0, I was able to drive about 3 stages without any problems, then the problem suddenly came here too, but it only lasted for a short time and disappeared by itself. I noticed this with different vehicles and routes. Thus, NFR appears to have a major impact, but is not the sole cause. In any case, the steering wheel is no longer turned to one side when I go to the menu.

    SEN = 1080, FFB = 50%, FFS = Peak, NDP = 15, NFR = 3 or Off, NIN = Off, INT = 5, FEI = 100%, FOR = 100%, SPR = 100%, DPR = 100%


    rFactor 2 feels very good at first and then becomes rough, it also feels choppy at times, as if interrupted, gas and brake then seem to respond with a time lag.

    SEN = Auto, FFB = 45%, FFS = Peak, NDP = 8, NFR = Off, NIN = Off, INT = 6, FEI = 90%, FOR = 100%, SPR = 100%, DPR = 100%

    All in all, the new driver and firmware is a step backwards for me and significantly worsens your product, and my confidence is also affected, because you don't know what's suddenly going to happen while driving and can no longer concentrate on the actual racing events.

    This is very unfortunate as I love my DD1 and am very keen to keep it working properly. If something changes, it should be an improvement and reduce the list of known issues.

    First I went back to version 415 with the base FW 686 and the motor FW 40, all games ran without problems, only with rFactor 2 I had to switch FFS from peak to linear.

    But since I like the driver 429 with the base FW 689 and the motor FW 41 better, I have now installed it again and can set rFactor 2 FFS back to peak. I will stick with this driver.

  • STILL?? I am sorry but I find that hard to belive that your still working on it, sorry

  • edited February 2022

    Aha. And what makes you assuming that Fanatec is lying? What gives you reason to not believe them that the firmware re-write is still ongoing when they officially write this?!

  • Hi Devs,

    CSW V2.5

    F1 2018 V2 + MPM

    CSL Elite LC

    V437 + Fanalab 1.62.3 up and running without any issue !

    THANK YOU 👉️💪

  • edited February 2022

    That means that it's not fixed and that they tried to fix it but got reports back that it didn't.

  • Maybe it's because it was announced that the firmware rewrite has been ongoing since the beginning of 2021, perhaps even earlier. In any case - it has been over a year since the first public announcement on that.

    It doesn't take this long to write firmware for a simple device - especially so when you work for the company that designed the device. It is beyond belief that dev team has been working on this for such a length of time which is why users express their exasperation. It is more likely that this work has been planned but not given priority or resources.

    It's no surprise that the dev team can't allocate resource to this - they have an endless battle fixing the new issues that are introduced with each update. If it is true that the dev team have been working on the rewrite for all this time, and still don't even have an internal beta version available then things are even worse - these issues will never be fixed.

    I've said it before but it is unfathomable why the beta branch and the release branch are not separate. There should at all times be a proven stable error free "Official" release that users can rely on. New features should only release into the beta branch so that they are fully tested by official beta testers before any public beta release. The public beta should only exist to pick up the odd gremlin missed by the official test team. That way things get fixed - only error free releases make it Official Driver status.

    As an example of the mess - there has never been a release for Podium DD that provides the functionality that was advertised - ITM on the wheelbase has NEVER worked reliably. Well over two years now since the product launched - this issue should have been fixed BEFORE launch!

    At the moment every Fanatec user is a beta tester because the real beta testers do a terrible job of smoke testing the software before release. It's beyond a joke.

  • edited February 2022

    Good that you seem to know exactly how the work behind the scenes is going and that you know that none of the issues were found... In reality there are several more issues which nobody in public even found yet which were discovered and reported by internal Testers. It's then up to fix issues with priority so some (known) issues will always need to be a bit left behind as you (obviously) cant fix all issues at once (the Jolt issue is definitely not an issue which is left behind, it has high priority as said multiple times already by Fanatec Staff.)

    Also if some issue slips through then that's because there are endless of possible hardware Setups in the Fanatec Eco System and Testers usually just dont have every product available to test - exactly for this reason there are public beta Tests to get more Feedback from a wider range of people with different Setups.

    Also regarding "error free" releases.... There will NEVER be a "error free" version of any Software. Thats just impossible. There will ALWAYS be some kind of errors, also in any stable release. That's how Software development goes. Or why do you think that pretty much every Software needs new releases or why Windows needs to fix dozens of issues every month?

  • Best to keep quiet, if you are not part of the beta program and you are only able to see from the outside :) And no, I don't think my beta tester colleagues and myself are doing a terrible job, who are you to judge that anyway.

    Like what Maurice has written, so many issues we have seen the public never got an eye on. It's always easy to moan about it if you haven't got the full picture is it?

  • I did but it started miss shifting again with the other hex file also. :( I ended up going back to using USB for my shifter for now.

    Hoping to get this solved by GT7 release.

  • You guys are hilarious. You really think this development is going well? In the three years or so that I've used Fanatec products it's gone from bad to worse.

    BTW - this is a user forum, sharing user's experience is what this is for - this isn't the first time you've attempted to silence me Sascha and I'd be grateful if you didn't do it again. Feel free to post if you have something useful to say but please don't try to silence valid criticism. Maybe concentrate on finding the bugs and not leaving that to the users. I'm sure you can do better than this mess.

  • I strongly agree...@Gagaryn The is not just a user forum, this is the BETA forum and if you are unable to take part in the BETA program without ridicule, I would suggest doing what Sascha Kaymer said in his post :)

  • this wasn't an attempt to silence you, this was more a suggestion. I feel insulted by your post, so again, best to stay out of this "mess" as you call it if you cannot cope with my reply. Maybe Marcel should invite you as beta tester, then we will see if you can do a better job :)

  • you should not get angry with us after all we have been waiting for a solution to the various problems for over two years. while the others continue the development we are still here looking for a more or less stable driver. Even with the qr2 nothing for months ...

    Remains the Trust in Fanatec that everything will be resolved. Do not Give UP

This discussion has been closed.