Fanatec Driver 380 Release Candidate for CSL, CSW and Podium Bases (all wheels)



  • Stewart ElderStewart Elder Member
    edited November 2020

    Panic over... deleted the drivers. Reinstalling and reflashed the wheelbase. Calibrated the wheel. And then calibrated then wheel in sim.

    Worked 100%.

    Cheers for your help...

  • Running a CSL Elite Racing Wheel (PS4), CSL Elite Pedals LC, CS Shifter and CS Handbrake. Been running official firmware included in official driver version 328 until end of August. Decided to try driver version 372, 373 then 374 and now on 380. All firmware updated to latest versions.

    Commented on the same topic on September 10th running driver version 374. The Compatibility Mode for the CSL Elite Racing Wheel (PS4) is not working as expected in neither yellow (Fanatec ClubSport Wheel Base V2) nor purple (6 axis 14 button device with hat switch) mode. Yellow mode will lock up when opening the Fanatec Wheel Properties with a Rundll32 not responding error. Purple mode opens the properties page, but no axis are working just the buttons and the hat switch.

    Still would like this to work since it is useful in older games and I assume Compatibility Mode is intended for that purpose.

  • Hi Maurice,

    I'd like to report that the power supply fans no longer shut off with this driver version. This has been the case for multiple days - the computer is off, the base is off yet the fans on the power supp are still going. No temperature change in the unit after the driver update.

    Is this a known issue?


  • Driver 380 exhibits the same behavior as 373 for me. Backing back to 365 fixes the issue.

    This is the same problem discussed many times and labelled as a hardware issue - if so why does it work with 365?

    This is where after a period of time the button box becomes unresponsive for a few seconds and then reconnects. Paddles and buttons do not work but steering and pedals do. Happens about every 10 - 15 mins.

    • Wheel Base Model (product ID): DD1 F1 for PS4 although running on a PC
    • Steering Wheel Model (product ID): .F1 Wheel for PS4
    • Driver Version: 380
    • Previously worked correctly on Driver Version: 365
    • Base FW Version: 679
    • Motor FW Version: V22
    • Wheel FW Version: /
    • FanaLab Version: 1.51
  • Hi Maurice,

    I have this same issue running on iRacing I was finding that I was getting little FFB information from the tyre slip, was finding there was no way to feel the lead up to oversteer and just struggling to contain or correct snap oversteer. As far a understeer was concerned it was more learning to guess when I could rely on the fronts from sight and sound. Only ways I had found was to increase Min Force in iRacing settings after a friend tried my rig and said your wheel base is crap there is something wrong and you need to send it back and have it looked at. I also discovered that putting it into CSW V2 mode was meant to overcome this, so I tried it and it seemed to provide some improvement.

    But before I contacted Support to discuss my issues I thought I should just update drivers and firmware thinking this would be the first thing I was asked to do, I also decided to try Fanalab, once complete, I started everything, went to switch to CSW V2 mode, everything froze, Fanalab went from seeing WB & Wheel to only seeing the WB and tells me in wheel connected via the images at the bottom. Re loaded everything a 2nd time but no changes.

    What can I do to get back trying to use the CSW V2 mode or actually testing my wheel to see if there is a problem or not?

    Rgds, Justin.

  • Hi folks, any thoughts on my question? I know it's not a bad bad problem, since it's solvable by downgrading to Motor firmware v20, but it would be nice to have an update, since it used to be listed as a known bug and has now gone (i.e. perhaps I have missed a better fix than downgrading). Thanks in advance!

  • I get the same thing also. Very notchy after just a little bit of use. I've gone back to v20. It may just be a placebo effect but in my mind v22 does feel better. Wish I could use it.

  • Hi, When driving last night and not being able to feel any under/oversteer in low speed corners I decided this simply wasnt right. I went back and checked the original driver package installed on my WB and found it was v328, I uninstalled v380, then installed v328 and flashed the WB with the firmware from v328. Straight away I was able to use CSW V2 mode and I went back on track taking an immediate 4 secs of my previous run and 2 secs off my blap and a sec off olap. This was all picked up on being able to feel the tyre. Justin.

  • I installed 380RC on my CSW 2.5 and also noticed the fan in my base is not turning on. So far, I've only run two, one-hour sessions with AI with FFB as high as the auto FFB in iRacing suggests. I guess I will try 373 and/or 328 another day.

    Is the fan supposed to turn on when the base is turned on and calibrating? Mine isn't.

    My base is 5-ish years old now.

  • Marcel PfisterMarcel Pfister Member, Administrator

    When these jolts are happening, which screen is active on the DD Display?

    • default FANATEC screen?
    • any of the analysis screens which show FFB and temparture stats?
    • any ITM screen with telemetry date from a game?
  • Marcel PfisterMarcel Pfister Member, Administrator

    Can you double check with a previous driver, for example 346 and 373 if the issue is happening there as well?

  • Marcel PfisterMarcel Pfister Member, Administrator

    If it happens again with driver 346 which is known for being stable and not having such issues you should contact support because it might be a hardware related problem.

    When trying previous drivers, always also downgrade to the older base firmware it contains to make sure an issue of the new FW is ruled out as well.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Does FFB go away and came back again shortly after or is it a permanent issue which is only solved by a restart?

    In case of the first issue you should try another USB port (USB 2.0, 3.0, front USB, mainboard directly, ....) and you can also check the device manager to make sure windows is not allowed to power save your device. Pictures attached on top of this comment.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Which game(s) are you having the issue with and is it possible to reliably reproduce the issue?

    I remember a game having such an issue, I think it was rF2. In that case everytime you go into the pits/menu and click on drive again it got worse and worse but I also think this issue got addressed by the dev already. Just want to be sure it's nothing like that causing it which would be out of our hands.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Some games/tracks have problems in the road surface, creating such jolts, In this case there is probably not much we can do as the base does what the game requests with the FFB signal.

    There are two examples which come to me mind:

    • iRacing, Mount Panorama, Start Finish straight there is one spot creating such a jolt
    • AC/ACC, Zandvoort, after the banked left hander and before the fast right hander which then goes down hill there

    Situations like that should not get reported as a jolt issue, only ones that are really random and are always in a different place for example.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Thanks for the report, we are working on a fix for the thumb encoders and the XBox mode being available. I'm not aware of any button delays though, we will give this a try.

    Also the toggle switch thing is new to me, can you try with an older driver and it's firmware like v346 and let me know if this changed since then? Want to rule out that the game isn't just showing the wrong side. We will double check this as well.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Can you describe it in more detail so we have a chance of reproducing and analysing your issue? Please make 100% sure you are using the exact same settings.

  • Sascha KaymerSascha Kaymer Member
    edited November 2020


  • Marcel PfisterMarcel Pfister Member, Administrator

    Glad you could resolve it.

    Did you re-install and re-flash driver 380 or an older one?

  • DD2 every time power on wheel rotates right only full rotation, im sure it used to do rotation right and return to centre with previous drivers

    while it meant to have unlimited rotation i would imagine the cable loom will endup over twisted over time, for now im going to do full rotation ccw every time i power it off

  • where did the wheel end up after you updated the base firmware?

  • you can also turn the wheel for hours into one direction and you wouldnt get an issue.

    Its normal for the startup that the base either turns a full loop or 50° to the right and then back to (almost) centre. Both is absolutely fine.

  • this shouldn't be driver related, more like a temparature thing.

  • Hi Marcel ,

    It has always been on the default screen with the Fanatec logo as i had read about problems with it being on the other screens so i always left it on the default screen.

  • what you described is how the DD2 used to behave before 380 update, now it goes right full rotation to centre and that is it, if you power cycle it goes full circle right again to centre. clearly something has changed and it isn't normal behaviour

  • Dear Sascha Franke, i have the same issue. on ps4 and f1 2020.

    podium racing wheel with dd1. before it was working but now with 380 the rotary thumb encoders do not work/irreguarly on the ps4. while they do work when testing all button functions on the pc

This discussion has been closed.