Fanatec Driver 456 (prev release candidate) for CSL, CS and Podium (all wheels)

Marcel PfisterMarcel Pfister Member, Administrator

How to report issues:

If you report a driver or firmware issue, please make cross checks:

  1. Update driver and FW separately to isolate an issue and find out if caused by driver OR firmware.
  2. Which driver OR firmware shows the issue
  3. Which driver OR firmware does not show the issue
  4. Check if you can reproduce the issue again if you go back to the version which seems to have caused the issue
  5. Check if the issue is related to specific settings of for example the tuning menu. Is it happening more or less with a specific setting raised or lowered?
  6. Post the answers gathered from the questions above + a short description of the issue including the following info:
  • Wheel Base Model (product ID): ...
  • Steering Wheel Model (product ID): ....
  • Driver Version: ....
  • Base FW Version: ....
  • Motor FW Version: ....
  • Wheel FW Version: ....
  • FanaLab Version: ....
  • Tuning Menu settings
  • Driver/FanaLab installed on C: drive or else?
  • With driver related issues collect log files and zip them from C:\Users\Public\Fanatec Logs

Changelog of driver 456 (since 455)

Firmware versions included

  • Podium DD1 / DD2 Base: (NEW)
  • Podium DD1 / DD2 Motor: 
  • Podium DD1 / DD2 WQR: 7
  • ClubSport DD(+) Base: (NEW)
  • ClubSport DD(+) WQR: (NEW)
  • CSL DD / GT DD Pro Base: (NEW)
  • CSL DD / GT DD Pro Motor :
  • CSL DD / GT DD Pro WQR:
  • CSW V1 Base: 693
  • CSW V2 Base: 693
  • CSW V2.5 Base: 693
  • CSL Elite Base: 693
  • CSL Elite Base PS4: 693
  • CSL / CSW Motor: 22
  • Podium BMW M4 GT3: 9  
  • Podium Hub: 6
  • Podium BME: 24    
  • Podium BMR: (NEW)
  • CS SW Formula V2(X), V2.5(X): 47 / (NEW)
  • CS SW RS: 4 
  • CS SW BMW V2: 3 
  • CS SW F1 Esports V2: 5 
  • CS UH V2 / UHX V2: 2 
  • GT DD Extreme SW: (NEW) 
  • GT DD Pro SW: 8
  • CSL Elite SW McLaren GT3: 37
  • CSL Elite SW McLaren GT3 V2: 47  
  • CSL Elite SW WRC: 4
  • CSL UH, CSL UH V2: 8 
  • CS P V3: 1.35
  • CSL Elite Pedals V2: 1.6
  • CSL Elite Pedals Load Cell Kit: 1.13
  • CSL Pedals Load Cell Kit: 1.8
  • CS USB Adapter - Handbrake: 1.10
  • CS USB Adapter - Shifter: 1.12
  • CS USB Adapter - CSL Pedals: 1.1
  • CS USB Adapter - CSL Elite Pedals: 0.1

Control Panel + Firmware Manager

  • Potentially fixed the stucked "Please wait..." window after a firmware update.
  • Fixed issues with feature test buttons which were caused by spamming the test buttons. Now the test buttons are disabled for the time of the respective feature test and get enabled again after the feature test finished.
  • Added a button on the Settings page to open the TrayApp.
  • Updated Wheel Base front pictures (when no Steering Wheel is attached) with QR2 pictures.
  • Updated Twitter (now X) Logo.
  • Other minor improvements.

TrayApp Version (optional installation)

Latest version of Fanatec App on Android/iOS (V0.1.14+126 or newer) required as well.

More info about the app on:

  • Added Desktop shortcut after installation.
  • Added EA WRC support. Notes on the Telemetry of EA WRC: ITM support for Gear, Speed and Current Laptime.
  • Added Forza Motorsport support. Notes on the Telemetry of Forza Motorsport: ITM support for Gear, Speed, Lap Number, Position, Current Laptime, Last Laptime, Best Laptime, Fuel (as percentage!) and Tire Temps. 
  • Fixed some telemetry issues in iRacing:
    • TimeLeft = -1 in PreStart phase.
    • TimeLeft = 1440 during lap based race.
    • RPM = 300 when engine is off.
  • Updated the App icon.
  • Updated Fanatec App ITM Telemetry support list.
  • Other minor improvements.

Podium and CSL/GT DD Pro Firmware Improvements

  • Potentially fixed Bases not going into Xbox Mode.

ClubSport DD(+) Firmware Improvements

  • Potentially fixed wheel communication freezes after some time of driving.
  • Fixed update issues with BME.

Steering Wheel Firmware Improvements

  • Fixed too weak rumble motors on the Formula V2.5(X).
  • Improved clutch paddles calibration on the GT Extreme wheel.
  • Note: With the latest CSL DD and GT DD Pro base firmware the steering wheel firmware version will be falsely detected as 0. Because of that the driver will suggest to update the wheel firmware even after it was already updated. Please ignore this update prompt.

Button Module Rally Improvements

  • Fixed MPS positions being off by 1 value.
  • Fixed ACP names being shown in wrong 7-Seg. abbreviations instead of full text.
  • Adjusted MPS LED colors.

Known Issues

  • With the latest CSL DD and GT DD Pro base firmware the steering wheel firmware version will be falsely detected as 0. Because of that the driver will suggest to update the wheel firmware even after it was already updated. Please ignore this update prompt
  • When entering a game menu while driving it can happen in some games that the FFB effect doesn't get canceled which results in the wheel turning to one side. (this got now fixed for the Podium DD but can still happen on the CSL DD. We will now apply the fix for the CSL DD as well)
  • Natural friction can start to feel weird after some time of driving. In case you experience issues with NFR, we suggest to turn it OFF for now. (this got now fixed for the Podium DD but can still happen on the CSL DD. We will now apply the fix for the CSL DD as well)
  • The steering input jump issue was greatly improved so the issue happens a lot less than before. Full fix expected for one of the next versions.

Compatible FanaLab Version




  • is there any way to bring my DD+ back into life?

    After pressing the Button, only a Faantec Symbol is shown at my 2.5X Wheel, no boot sequence or any LED light at the Button.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Do you have driver 455 or 456 installed?

    Then open the Driver Control Panel, the base might be stuck in update mode but the Control Panel can detect this and automatically start the firmware update to bring it back into a functional state.

  • Thank you for the quick response, i try the 456 Driver Version.

  • Hello 

    Is there a fix for the sound emitted in the DD+ base (like the wind, it sounds like "magnets") or is this a technical problem that cannot be managed by an update?


  • * Anomalous and distinct sound, of course, which comes on very quickly 

  • Allan LehtlaAllan Lehtla Member
    edited February 23

    have issue with the Clubsport steering wheel formula V2.5 it shows a firmware 0 in the Csl DD but at DD2 is shows the 47

    in other words at Csl DD it goes forever loop by try update

  • Not sure if this is even still an issue now with the DD+ WQR2 firmware update freezing after telling you to remove the wheel but earlier this morning before this 456 driver came out I got mine to update normally by just simply booting up my PC, closing fanalab since it auto starts, opening fanatec control software, removing the wheel from my base. Powering on the base in PC red light mode. It said update available for WQR2. I clicked Ok, it opened firmware manager and updated instantly. So it seems the trick is to not have a wheel on the base at all and fresh boot of everything. Fresh boot might not matter but just telling everyone how I did it with no issue.

    Again, this might not even be an issue with 456 firmware but just incase anyone runs into it.

  • Thats a hardware issue, not possible to fix hardware issues with FW. If your base is affected by the coil whine issue, then you should contact the support.

  • Gökhan OgulGökhan Ogul Member
    edited February 23


    With Driver 456, my F1 eSports V2 is now recognized at any time during cold start (with attached wheel) or when plugged in after startup! Tested with two F1 eSport Wheels V2 and started the base more than 10 times and now it is recognized every time!!

    THANK YOU FANATEC !!! You have fixed the problem! What was the issue? what has caused it? I hope I could help you find the error.

    My RMA can be closed because this issue!

    Finally, now I have the perfect base that works fine!

  • When starting my CS DD+ base (every firmware updated including those from 456 driver) it remembers my last used mode, ie PC, Playstation etc, except the Xbox mode. There it starts in PC mode instead. If I remember correctly the CSL DD Pro base hade the exact same problem in the beginning, but it was fixed about a year or more ago I would say. Not sure if the problem is in the base or the Xbox compatible wheel (in my case the CSL Elite Steering Wheel McLaren GT3 V1). I have no non-Xbox wheel to test with.

    Also compared to my CSL DD Pro base I would say it's close to 1 second slower when switching between the modes (at least the lights changing), and the slowest is the Xbox mode. I guess it's all related. No big deal perhaps but I would expect things to be at least as responsive as on the old base so can only guess it's a software issue?

  • I did so as early as last Sunday, but still no reply despite my reminders. I'm extremely sad and disappointed. 

  • Sending several reminders wont give you a faster answer. In fact, it makes the overload even worse and you have to wait even longer for an answer.

    I just got an answer today for a question from 2nd January...... I dont say it always takes this long but you only waited 5 working days, that's well within their current response time of estimated 2 weeks. You will need some more patience, but you will get an answer.

  • Hey Maurice,

    DD2 with Formula V2 XBOX wheel on 456 and importantly base firmware has fixed not being able to select XBOX that I had in 455 /



  • I didn't create several tickets, I just replied to the email (X2) I received when I made my request. 

    Thank you in any case for your response, good weekend to you. 

  • edited February 23

    I will like to know this as well.

    I received couple of days ago, Everything was good when I installed, no sound, quiet. I did the 455 update drivers/firmware, all fine. Then I used for maybe 1-2 hours, performance, everything was good besides the extreme wheel crashing, which was known issue. Then when I shut down the game, I heard the noise you are talking about. Whining, whistling, always changing high low pitch, attributed to Coil Whine. I was disappointed :(.

    in morning, I turned it on, no noise. maybe 5-10 minutes later, noise came back. I have discovered when it is off for a while, it is cold and when I turn it on, No noise, after it warms up even a little (5 minutes), I get the whine noise again.

    I just updated everything with 456 driver/firmware package, all went smooth but noise still there.

    NO impact in performance that I notice, but it is VERY VERY annoying because it is high frequency and easy to hear now when waiting in lobby or menus and not racing.

    Can this be fixed with firmware? is it like motor parameters that need to be adjusted maybe? Do I have to RMA? I don't like the thought of going with that, if it is, maybe I will exercise my right to refund because I received defective product, I don't want to pay $ to ship a big heavy box because I want to return since it is defective unit. I don't think this problem can be fixed, on replace unit, no guarantee new unit will not have same problem because of same batch of manufacturing.


  • As already answered: Coil Whine is a hardware issue and can not be fixed with Firmware. Please contact the support.

  • I appear to be stuck in a Podium hub firmware update loop. The firmware manager reports version 0 and I run the update which appears to be succesful but the manager still reports version 0 and tries to update to version 6. This cycle repeats. Any ideas?

  • Gökhan OgulGökhan Ogul Member
    edited February 23


    Base: Clubsport DD

    Steering Wheel: F1 eSports V2 , Firmware 5

    Driver: 456

    Base Firmware: 2.0.26

    WQR Fimware:

    Fanalab: v2.01.27

    Bug: During Racing the Base lost the Connection & FFB to the steering wheel. But the display on the steering wheel was always enabled with latest speed value. Looking to the driver shows: No Steering Wheel and WQR Version was: Restarting the Base works an the Steering Wheel booting up, but the driver still shows no Steering wheel and WQR still on Only restaring the PC has helped and Steering Wheel is recognized (Driver Side) with displayed WQR Version Looks like a Bug Driver (PC)-Side. On Firmware Side seems to work, The Steering Wheel was always recognized by base and booting up has worked alltime. Only the Driver has lost the connection.

    This was happens only one times after playing for 2 hours.

    I hope it helps for optimize the driver.

  • just leave it like it is, seems some-sort bug that when use csl dd then it cant detect the firmware version

  • ScSc Member
    edited February 23

    installed 456 and updated base and WQR FW without any issues on dd+

    one thing I noticed while cycling through the modes (with the power button and button combo on the wheel)

    the order should be red, purple, yellow, green (if Xbox wheel is attached) and blue. But when I switch from red to purple the led is white and on ps5 it’s recognised as gt dd pro and is working fine. After switching again it gets into purple mode.

    not an issue for me since I play only on ps5 but wanted to let you know

  • We can confirm tis issue that every wheel gets detected as FW V0 on a CSL DD and GT DD Pro.

    This should be fixed with the next firmware in the next driver in March.

  • edited February 23

    OK, I had some time to try new firmware with DD+ Extreme on PC. All updates went smoothly.

    Also Updated Fanalab to latest v2.01.28

    The LCD on extreme wheel just won't work. on 455, it worked but would freeze after some time. on 456, NOTHING.

    it's always on the primary screen, NO telemetry data, won't do anything at all. Just stuck on main screen that is in Fanalab profile (Maurice's profiles for iRacing and ACC). No matter what I try, will not change or work.

    This is very annoying.

    I also feel, along with the freaking coil whine, it is now developing cogging even when in race on new firmware and 456 drivers, before it only had cogging when turned off and smooth on 455. Now it is cogging during the race and it's worse than when it's off... how is that possible? This is supposed to be a "Smooth" base.

    Aghhh, looks like I will have to return for refund. This is terrible, I will lose $ I paid Fanatec for shipping and I will lose $ I have to pay to ship back to them. Fanatec... I want to KEEP it, but why should I have to pay to return essentially a DEFECTIVE bad product???

    or I RMA and take a big chance of getting worse replacement and wait months.

    Either way, I am screwed.

  • ClubSport Steering Wheel Formula V2 Firware update keeps looping and not installing

    It says I have firmware 0 and that V47 is available! but when I install the update it just loops back to saying I am on firmware 0 again and says V47 is available.

    I have tried restarting my pc I have also power cycled the CSL DD but the firware loop issue persists.

  • See above.

    Known issue that that every wheel gets detected as FW V0 on a CSL DD and GT DD Pro.

    This should be fixed with the next firmware in the next driver in March.

  • Just updated to 456 driver on my pc using my DD+ wheel base. Everything went fine. Upgraded all the firmware updates that were available. However, I still cant seem to find a way to make my DD+ wheel base + WRC elite or Mclaren GT3 wheels to work in my Xbox series x while playing forza motorsport. The biggest issue is that my pedals are not being recognized. The gas and brake pedals are not working at all. They work in every other games including dirt rally 2 and EA wrc and it even works fine with forza while playing on my PC. It just doesn't work on Series x.

    Any help would be appreciated. Thank you

  • I keep getting an error message that a dll hasn't been installed. I've reinstalled the new driver install package but this is what I keep getting.:

    It looks like I can install the new firmware after clicking thru the multiple dialogs, but not sure that I want to take any chances.

    Maurice - any thoughts?

  • sean pirtlesean pirtle Member
    edited February 24


    Not a PC guy, but figured it out - reinstalled the microsoft runtime library and the dll was reinstalled.

  • MadDog-ICMadDog-IC Member
    edited February 24

    That DLL is a part of the Microsoft "Visual-C-Runtime Libraries", so you will need to download from Microsoft and install or repair:

    1) vcredist2010_x64.exe

    2) vcredist2015_2017_2022_x64.exe

    Not sure which runtime Fanatac Control Panel needs, but I suspect the two of these would be most likely to cover it.

    Filenames may be the more generic (VC_redist.x64.exe).

  • Hello ,

    Yes, there is no noise when cold, but it starts after about fifteen minutes of play and gets louder over time. The last time I used it I even felt some kind of abnormal vibrations in the steering wheel due to this problem. I haven't used it for 4 days now, and I'm very "frustrated" for a new product at this price. I hope that the support team will get back to me and quickly take charge of the base for an exchange. 

This discussion has been closed.