Fanatec Beta Driver V347 for CSL, CSW (all wheels)

edited September 27 in Beta drivers
Hello Everybody,

Take a look at the known issues before downloading! DD users might want to skip this version.

Changelog of 347:
1. Fixed issue that H-Shifter Button overlaps in the Wheel Calibration Buttons.
2. Fixed issue that Settings Page and Update Page does not close when USB is disconnected.
3. Disabled the H-Shifter button if the H-Shifter is not connected.
4. Podium DD now supports up to 2520 degrees of rotation in the [SEN] Sensitivity setting of the Tuning Menu.
5. Fixed Formula V2 prompting two messages when booting the DD. Potential fix for the crashes.
6. Fixed Podium DD Fan Speed 100% when booting while 0°C temperature and Motor Driver 0 shown.
7. All bases now should support the new shifter calibration in the driver. 

Firmwares included: 
   - CSW V1 Base : CSW_Base_V664_rev1712_app (NEW)
   - CSW V2 Base : CSW_V2_Base_V664_rev1712_app (NEW)
   - CSW V2.5 Base : CSW_V2_5_Base_V664_rev1712_app (NEW)
   - CSL E Base : CSL_E_Base_V664_rev1712_app (NEW)
   - CSL E Base PS4 : CSL_E_PS4_Base_V664_rev1712_app (NEW)
   - DD Base : PDW_DD_Base_V664_rev1714_app (NEW)
   - EBLDC : CSLEWBPS4_CSWBV2.5_EBLDC_V22_rev335_app
   - EBLDC DD10 : PWBDD1_EBLDC_V34_rev401_app (NEW)
   - EBLDC DD20 : PWBDD2_EBLDC_V34_rev401_app (NEW)
   - RMCL : RMcL_V30_rev38_app
   - RFORMV2 : RFORMv2_V28_rev113_app
   - PHub : SW_P_Hub_V2_rev128_app

Known Issues:
  • After updating Podium DD to 664 the fan will run at 100% until you update Motor Driver to v34!
  • If you have a Podium DD you might experience bad FFB noise, please run the motor calibration in the driver and turn down FEI a bit to 70 or so and see if it helps you. 
  • Sorry the "notchy" issue of CSW V2.5 and CSL E PS4 which some testers experienced is still under investigation and couldn't get fixed yet. I've attached motor firmware V20 which has less coil whine than V18 and less notching than V22 according to some testers. 
  • There might be issues with the new max rotation of 2520° on the DD and FanaLab 1.12 because it wasn't updated to support this yet. 
If you report a driver or firmware issue, please make cross checks:
0. Update driver and FW separately to isolate an issue. Most likely it will be driver OR firmware.
1. Which driver OR firmware does show the issue
2. Which driver OR firmware does not show the issue
3. Check if you can reproduce the issue again if you go back to the version which seems to have cause the issue
4. Post the answers gathered from the questions above + a short description of the issue including the following information:

Wheel Base Model (product ID): ....
Steering Wheel Model (product ID): ....
Driver Version: ....
Base FW Version: ....
Wheel FW Version: ....

Thank you very much!

We hope for your positive feedback! 
«13456

Comments

  • edited September 27
    Everytime I try to update my wheel motor firmware the driver window says (no response) and can't do anything when clicking in connect.

    Updating wheel firmware works perfect.

    Want to try the motor FW V20 with my CSL V1.1

    I have W10 Pro 1903 update.

    Wheel Base Model : CSL V1.1
    Steering Wheel Model (product ID): Formula eSports
    Driver Version: 346
    Base FW Version: 662
    Wheel FW Version: 22

    Update: Fixed, now I have Motor FW 20, gonna test.
  • Can you tell Me what this is.... . "Added PBME Detection in the Firmware Updater"
  • Can you tell Me what this is.... . "Added PBME Detection in the Firmware Updater"
    Doesn't affect you, deleted it to not cause confusion. It's regarding the Podium Button Module Endurance, the one that was shown in combination with the new Porsche wheel at the Sim Racing Expo. 
  • edited September 27
    Auto Sensitivity is broken with the new driver/firmware. I load a FanaLab profile, where Auto is saved as sensitivity. But in the Tuning Menu the value will be changed to 2360 and I have to manually set it back to auto everytime... I think this is because FanaLab cant see the more degrees of rotation yet as it reads the values completely wrong which you can see in the FanaLab Tuning Menu Tab?!
  • Hey Fanatec, could we please please please have an option to disable the high torque warning on Podium DDs? You could even have the option if you have the e-stop attached? Maybe get a few more sales in?
  • edited September 27
    Wheel Base Model : Podium Wheel
    Steering Wheel Model (product ID): Formula Wheel that comes with the Podium Wheel
    Driver Version: 346
    Base FW Version: 664
    Motor FW Version: 34
    Wheel FW Version: 28

    Sim: iracing

    2160 degrees are recognized, but not translated right by iracing. Now a 90 degree wheel turn translates into a 45 degree wheel turn in the sim.

    Some "trickling" FFB in the steering wheel grip motors or the main motor (can´t tell for sure…) without even driving,


  • Wheel Base Model : Podium Wheel
    Steering Wheel Model (product ID): Formula Wheel that comes with the Podium Wheel
    Driver Version: 346
    Base FW Version: 664
    Motor FW Version: 34
    Wheel FW Version: 28

    Sim: iracing

    2160 degrees are recognized, but not translated right by iracing. Now a 90 degree wheel turn translates into a 45 degree wheel turn in the sim.

    Some "trickling" FFB in the steering wheel grip motors or the main motor (can´t tell for sure…) without even driving,
  • Okay so my DD1 Wheelbase would not be shown after the FW Update 664 after I restart my computer and the WB for several times. Fan wnt full speed until I was able to update to Motor FW 34. But I have to say that this FW feels way worse than FW 30. So I tried to rollback to Driver 346 with driver 662 and Motor FW 30 and now my DD1 is stuck at CAL on start up, it won't show up in the property page and the fans run full speed again!

    Wheel Base: DD1
    Base FW: 664/662
    Motor FW: 34
    Wheel FW: 28 (F1 2018 LE Formula Wheel)
  • edited September 27
    Podium Wheel Base FW Version: 664 Motor FW Version: 34 Wheel FW Version: 28 Fanalab doesn’t support the 2160 degree range of the new 347 software, see my post in the Fanalab forum for details. Some strange constant „trickling“ FFB in the wheel, even when not driving or even in a sim, seems to come from the motor rather than from the vibration devices in the wheel. VERY distracting when driving as you as a driver don’t interpret the actual FFB right anymore. Really liked all betas so far, but this one I‘ll uninstall.
  • Podium Wheel Base FW Version: 664 Motor FW Version: 34 Wheel FW Version: 28 Fanalab doesn’t support the 2160 degree range of the new 347 software, see my post in the Fanalab forum for details. Some strange constant „trickling“ FFB in the wheel, even when not driving or even in a sim, seems to come from the motor rather than from the vibration devices in the wheel. VERY distracting when driving as you as a driver don’t interpret the actual FFB right anymore. Really liked all betas so far, but this one I‘ll uninstall.
    I feel the same strange "effects" from the base, you can even hear them, when using it! How can I roll back to Motor FW 30 again?
  • same here, please instructions, thx

  • edited September 27
    DD2- Lots of rackeling in the motor after this update :S (same as the guys above probably)
    Feels really strange, i will rollback until further fix :)


    Also i got a little usb problem i think? sometimes i need to reinstall the drivers to make the pc register the DD2. someone that knows a solution on that? :) (restarting the computer dont work btw, and i dont see any special pattern in when i have to reinstall the driver...)
  • edited September 27
    I feel the same strange "effects" from the base, you can even hear them, when using it! How can I roll back to Motor FW 30 again?

    Good to know I‘m not the only one feeling that!
  • Please everyone with a DD run the motor calibration as instructed after the updates! 

    Compare with motor calibrated and with calibration erased and let us know the difference.
     

    image
  • edited September 27
    If you experience FFB noise with the DD lower FEI to 70 or so end report if it helps. 

    I've just noticed that with FEI 100 I get a lot less oscillations on the DD with this driver and firmware I can use significantly less NDP now. Recognized more road feel though which can be filtered out with lowering FEI if you don't want it, sadly then the oscillations might come back.

  • edited September 27
    Please everyone with a DD run the motor calibration as instructed after the updates! 

    Compare with motor calibrated and with calibration erased and let us know the difference.
     

    image

    No difference in oscillations between erased motor calibration or calibration done. The oscillations change with NRF. They are not completely gone when NRF is OFF, but very very subtle then. As soon as you turn NRF to 1 you start feeling the oscillations. It’s hard to say if they increase with increasing NRF, to me the oscillations at 10 feel the same as at 50 or 100. For me changing FEI doesn’t change the oscillations. No difference between any FEI value, NDP also has no influence on the oscillations. Interestingly, now I reverted to 346, and there is oscillation, too. It is much more subtle than at 347 and does not change with any of the values. Now that I knew what to „feel for“ I got aware of that. I hadn’t noticed it before in 346.
  • edited September 28
    After resetting and calibrating several times, the strange feeling and vibrations won't go away, so I think I will roll back too... DD2
  • roll back for the same reasons
  • Please everyone with a DD run the motor calibration as instructed after the updates! 

    Compare with motor calibrated and with calibration erased and let us know the difference.
     

    image

    No difference in oscillations between erased motor calibration or calibration done. The oscillations change with NRF. They are not completely gone when NRF is OFF, but very very subtle then. As soon as you turn NRF to 1 you start feeling the oscillations. It’s hard to say if they increase with increasing NRF, to me the oscillations at 10 feel the same as at 50 or 100. For me changing FEI doesn’t change the oscillations. No difference between any FEI value, NDP also has no influence on the oscillations. Interestingly, now I reverted to 346, and there is oscillation, too. It is much more subtle than at 347 and does not change with any of the values. Now that I knew what to „feel for“ I got aware of that. I hadn’t noticed it before in 346.
    I tought it was just me (placebo effect). I feel it too now with 346, but it doesn't change with NFR like with 347
  • edited September 28
    Please everyone with a DD run the motor calibration as instructed after the updates! 

    Compare with motor calibrated and with calibration erased and let us know the difference.
     

    image
    Hi Marcel, I updated the base and did a new Motor Sensor calibration. I will try the FEI 70 setting.

    Update: Didn't help much regarding the strange feel and noise from the base. I rolled back to 662 with Motor FW 30.
  • Rolled back too, greatness is back
  • Driver Error - Can not use v347

    System: Windows 10 64-bit build 1903 (all updates 28/09/2019)

    Wheel Base Model (product ID): FANATEC CSL Elite Wheel Base PlayStation 4
    Steering Wheel Model (product ID): P1
    Driver Version: v347
    Base FW Version: v664
    Wheel FW Version: n/a
    Motor FW Version: v22

    v347 Driver install and Base FW updated to v664 on 27/09/2019 - didn't test but could get in to Fanatec Wheel Properties so seemed okay.

    I performed a complete fresh install of Windows on 28/09/2019


    On installing v347 I was unable to enter the Fanatec Wheel Properties and found the following issue in Device Manager:

    image

    Notice all the hidden USB devices and there is no Fanatec device.

    Kept the all the Firmware the same and installed driver v346 and now have the following as expected and the wheel works:


    image
    Notice there is no longer any hidden USB devices.

    I uninstalled v346 (using the "How to reset game controller to default" which I found somewhere in this Forum)
    Re-installed v347 and had the same issue.
    uninstalled v347, reinstalled v346 and all is working as expected.

    I am unable to use drivers v347, I have reverted back to v346 but still using the latest Firmware that came with v347

    Kind regards. 
  • edited September 29
    Entire DR 347 package is a No Go for Me...I immediately felt Notching and Small Vibrations in the wheel with No Game Loaded.
    Aslo Take Note the New FW causes problems with with the PC detecting the wheel base while Rim is attached... Once wheel rim was removed the wheel base was detected right away

    Windows 10/64bit , Build 1903
    DD2 w/Universal Hub + APM
    Driver Version: 347
    Base FW Version: 664
    Motor FW 34




    Went back to DR 346 and FFB Perfection  is Now back ;)

    Windows 10/64bit , Build 1903
    DD2 w/Universal Hub + APM
    Driver Version Version:  346
    Base FW: 662
    Motor FW: 30




    ;)
  • i've also rolled back to 346. I've a CSW 2.5. It feels better. Perhaps placebo, but I am happy. 
  • Okay so my DD1 Wheelbase would not be shown after the FW Update 664 after I restart my computer and the WB for several times. Fan wnt full speed until I was able to update to Motor FW 34. But I have to say that this FW feels way worse than FW 30. So I tried to rollback to Driver 346 with driver 662 and Motor FW 30 and now my DD1 is stuck at CAL on start up, it won't show up in the property page and the fans run full speed again!

    Wheel Base: DD1
    Base FW: 664/662
    Motor FW: 34
    Wheel FW: 28 (F1 2018 LE Formula Wheel)
    The same thing happens to me too!:(
  • Okay so my DD1 Wheelbase would not be shown after the FW Update 664 after I restart my computer and the WB for several times. Fan wnt full speed until I was able to update to Motor FW 34. But I have to say that this FW feels way worse than FW 30. So I tried to rollback to Driver 346 with driver 662 and Motor FW 30 and now my DD1 is stuck at CAL on start up, it won't show up in the property page and the fans run full speed again!

    Wheel Base: DD1
    Base FW: 664/662
    Motor FW: 34
    Wheel FW: 28 (F1 2018 LE Formula Wheel)
    The same thing happens to me too!:(
    When you roll back to 662, overwrite the Motor Firmware first, so the base is still shown in the property page. After that you can roll back to Base FW 662 and everything is fine. Don't forget the motor calibration after that. :)
  • I didn't experience any of the above issues with my DD1 PS4. Only thing I didn't like was overall ffb feel, so downgraded to fw 662 and motor fw 30 too.
  • Looks like ill stick with 346 for the time being.  too many issue
  • Wheel Base Model (product ID): CSW v2
    Pedal Model (product ID): CSP v2 (wheel connected)
    Steering Wheel Model (product ID): CS Formula
    Driver Version: 345 & 347
    Base FW Version: 662 & 664
    Wheel FW Version: unknown

    Issue: Brake rumble motor does not operate via driver test nor software like FanaLab or FanaLEDs. The rumble motor DOES work, but only in junction with the ABS function on the wheel, yet it does not work at all via driver/software at all no matter if set to OFF or an X-percentage. The rumble motor also tests fine in driver when the pedals are connected to USB, and they also work in software.
Sign In or Register to comment.