FanaLab 2.00.09 Release Candidate (prev. 1.99.02) - Post your Feedback here



  • edited July 2023

    This could not be reproduced internally from several testers and the devs. Windows goes properly into sleep mode just fine for everyone else, so this is not seen as a FanaLab issue but more as a Windows issue specific to some PCs and is therefore currently not further investigated.

  • Hey Guys,

    having the issue that on my Formula V2.5 with CSL DD the shifter leds seem to get two signals. Like one from the game and one from (the latest version of) fanlab. Updated today and loaded fresh profiles from Maurice. In the Porsche GTE I can see the original (from left and right to the middle) and the classic left to right shifting lights.

    Profile ingame is set to PC2…

    Any suggestions?

    thx in advance!

  • You need to click the two green buttons in the game profile Tab in Fanalab to Enable Telemetry and Enable Fanalab support to disable native game support so they dont interfere with each other. Either Fanalab can set everything up on it's own or you get some instructions shown what you have to do. You have to do so for every game.

  • Steven CuberoSteven Cubero Member
    edited July 2023

    No it isn't "fine for everyone else" maybe for the majority, but there are plenty of people with this issue, and just a quick search:

    So apparently, the people that have this problem must be related to a Windows issue even though it only happens when Fanalab is running? Right.

    Again, it only happens when Fanalab is running which clearly indicates the problem isn't with Windows..

  • edited July 2023

    Yes, correct, the very few people who have that issue might have some specific Windows setting which is causing the issue.

    As said, this is no widespread issue, this could not be reproduced in dozens of tries from a lot of internal testers as well as the devs itself, so there is nothing which can be done from FanaLab side as issues only can be investigated (and fixed if they are FanaLab related) when they can be reproduced, and this is one which just can not be reproduced because only a very few people in the world have this issue, therefore its more likely to be a Windows issue on the affateced PC's at this point.

    So I am sorry but there wont be a fix anytime soon from FanaLab.

  • Marcel PfisterMarcel Pfister Member, Administrator

    1.99.05 hotfix available

    • Fixed crash on Base Mode Change (PC Mode -> CSW V2.5 Comp. Mode -> PC Mode).
    • Fixed Pitlane LEDs not working in iRacing.
    • Changed default LED setting from RPM to % mode with more linear default threshold values.
    • Added save / load logic to the expanders so when you collapse one group of settings then the status now gets saved and properly loaded on the next FanaLab restart so the group now stays collapsed.
    • Added warning to the hints that no live telemetry is sent to the Podium BMW M4 GT3 wheel as long as the Color Picker or Display settings are open.
    • Added new CarsList for AMS2 Update V1.5 & Adrenaline DLC (new: Ginetta G58 Gen2, MetalMoro AJR Gen2 Chevrolet, MetalMoro AJR Gen2 Honda, MetalMoro AJR Gen2 Nissan, Sigma P1 G5, Formula Dirt, Kart Cross, Citroen DS3 RX, MINI Countryman R60 RX, Mitsubishi Lancer Evo10 RX, Volkswagen Polo RX; changed: all "VW" cars were renamed to "Volkswagen").
    • Added new CarsList for R3E Porsche Pack 2023 (new: Porsche 944 Turbo Cup, Porsche 944 Turbo Cup, Porsche 911 GT3 Cup (992) Endurance, Porsche 992 GT3 Cup, Porsche 911 GT3 Cup (992), Porsche Carrera Cup Deutschland 2023, Porsche 911 GT3 R (992) , GTR 3, Porsche 911 GT3 R (992) DTM).
    • Various other minor fixes and improvements to the new visual appearance of the UI.

  • edited July 2023

    And right in time for FanaLab V1.99.05 (even though it's quite late and I actually was half-sleeping already but the upload threw me off the bed) here are also my newest profiles which are ready for both this V1.99.05 as well as the upcoming official V2.00.00 (which is planned to be basically V1.99.05 just renamed because V1.99.05 is the final RC).

    This update is mainly focused on AMS2 and does not include changes to profiles of other games compared to my previous upload for FanaLab V1.99.02.


    • Added new profiles for AMS2 V1.5 & Adrenaline DLC cars.
    • Added Pit Limiter and DRS FlagLEDs and Button LEDs to some AMS2 profiles where those LEDs were added with latest game update.
    • Updated ProfileCarsList_AMS2.xml file to include the new cars to be directly bound to the respective profile.
    • Updated ffb_custom_settings.txt file to Danielkart V90 (with some specific adjustments to tailor my needs like disabling scrub effects, enabling flatspot effects and reducing kerb smoothing).
    • Updated in-game FFB settings for AMS2, see the README file.

    As always: Have fun with the LED p0rn and FFB madness :)

  • Marcel FrühMarcel Früh Member
    edited July 2023

    Hey guys, I have a problem and I hope you can help.

    It's about the new Fanalab beta 1.99 and F1 23 in combi with SimHub, CrewChief, RaceLab and Fanalab.

    In the latest public release of Fanalab 1.69, where F1 23 is not included, I did configure the configuration.xml of Fanalab from the F1 22 exe to the exe of F1 23. The UPD Format in game was 2022 and all worked well. In Game UDP was set to 20888, SimHub listened to this Port and forwarded it to 20777 CrewChief, 20778 RaceLab, 20779 Fanalab. All worked.

    Now in the new beta 1.99 Fanalab listens to UDP Format 2023 and now CrewChief do not work anymore. If I switch in game to UDP Format 2022 CrewChief works again, but Fanalab no more. Racelab seems not to be influenced.

    What can I do? Do I have to switch back to the latest release and reset my old config? Or did someone solve that in an other way?

    Thx, Jah

  • edited July 2023


  • It actually seems that CrewChief does not support F1 23, so there is nothing FanaLab could do here, it's up to CrewChief to implement F1 23 support to work then with 23 UDP format.

  • @Maurice

    I'm using your profiles and I noticed that when I change any of the settings in Telemetry Data List, then also Gear is disabled.

    Once I save the settings and then alter one of the setting in the Telemetry Data List, then this is not happening. Only when I load one of your profiles for the first time.

    Not really a big problem, but was wondering if that is something on my PC.

    Also was wondering if there is or could be an option to copy the LED color setting to a different car.

  • You mean when you set any of the available settings to "C" for Constant then the "Gear" gets disabled? Thats intended. Only one setting can be set to Constant and the previous Constant setting intentionally gets disabled when you set a different setting to "C".

    Regarding the other question, thats not possible from the FanaLab UI itself, you could only manually copy the <LedBacklightButtons> from the pws file itself into other pws files.

  • That I can not reproduce. Nothing is changing for me when I set a setting to 1-3. Everything stays as is.

    So no idea what the Problem could be and unlikely to be fixed when it's not reproducable, sorry.

  • Ok, now this is strange. I had this issue from the beginning and all versions of Fanalab till this morning when posting this. Now I'm trying it again and the problem is gone. You have some magic where you can change something on my PC ;)

    Copying the <LedBacklightButtons> also copies the LED lights for the pit limiter? Tried it and think the car specific pit lights are over writen with the ones from the copied file. Just asking, because i'm not trusting my self anymore with the issue from above ;)

  • Haha ok, magic! :D

    Regarding the Button LED copy: Everything which you copy between the lines <LedBacklightButtons> and </LedBacklightButtons> (298 lines in total) gets copied to the pws file where you paste it, this includes the Constantly set Button LÖEDs and all three available telemetry slots with colors and brightness. It's basically a full 1:1 copy.

  • Michel BoschMichel Bosch Member
    edited July 2023

    Ok thanks. If i'm going to copy it that way then I loose your hard work on the pit limiter lights :)

    Going to do it manual. It's only for a couple of cars so not a big problem.

    Also just found out (by digging into this) that you can set colors with the Prio low option for ABS/TC telemetry info. Now we need to flashing LED lights with the wheel ;)

    edit: it already flashes with abs and tc

  • Thanks that fixed some of the cars, but for exampel audi evo and evo II and lambo huracan st evo 2 still not seems to be recognized.

  • Well, then simply bind them on your own, takes just 2 seconds per car and is for sure quicker than investigating where the issue is with copy/pasting ;)

  • Hi,

    I'm still on 99.03 but I don't see anything regarding this on changelog, does anyone Elsa have problems with F1 23 not always loading the profile or even the correct profile? For example sometimes I enter career mode with "my team" but Mercedes profile gets loaded, other times when doing the time challenge it loads the correct supercar profile but than when going to practice it stays on the supercar profile...

    Hope it was clear.

  • Did you made sure that every car is correctly bound to the respective profile, so does every profile show the car icon in front of the profile name?

  • I copied your files as usual, but I'm gonna try to clean everything and start from scratch

  • Can't get the LEDs to work with F1 2023. I updated to the latest FanaLab and ensured the settings are the same as recommended in the recommended settings in the game.

    In FanaLab the options to enable telemetry or LEDs is grayed out, cannot select them, and next to the UDP Port info on the game telemetry settings when my profile is active in FanaLab there is no value.

    What can I do to try and resolve this?

  • edited July 2023

    Sounds like you added the game as Custom Game instead of using the native game support?

    Also do you use the Steam or EA Launcher version?

    Can you post a Screenshot of the Game Profile Tab?

  • For the matter, mine is EA...

    Is it so difficult to implement EA on fanalab? Instead of having to edit manually?

  • edited July 2023

    Not possible to implement the game natively via EA Launcher into FanaLab, no.

    But the Setup is easy, just not plug&play like Steam.

    For EA Launcher version you need to manually click the Windows logo on the Main Tab in the picture of the game to select the game exe file by yourself - not to confuse with adding a custom game as Custom games dont give Telemetry! Steam is easier as it's all set-up automatically.

    But once the exe file is manually selected it will work the same as the Steam version.

  • Yes I know, that's what I've done...

    What i was asking is if it is too much trouble to add it to fanalab as steam, I'm not a programmer, but I don't think that would be that hard to be an autonomous operation...

  • Answer already given in the above message :)

    It's (natively) Steam only for FanaLab.

  • Mine was EA and your advice solved the problem. When I purchase it on Steam, just uncheck the windows logo and I can go back to the default steam integration for launching / telemetry? Thanks for all the work and advice.

  • Actually it didn’t work. Set the game to the exe manually with the windows logo and it still doesn’t show any UDP port number or LEDs in game.

This discussion has been closed.