Podium Wheel Bases (and Racing Wheels) discussion



  • Just got to use my Fanatec dd1 for about 3 hours and suddenly it loses all power and I’m not able to power up. I’ve updated the software and I’ve checked the power cord and I’ve checked the internal fuse. Any suggestions? I’ve tried to contact support (Lol).

  • Hi all, just wondering if the wheel base information that shows up on the OLED is also displayed anywhere else? I was thinking of getting a DDU that may cover the wheelbase temp readings etc and was wondering if that wheelbase info can be displayed anywhere else like in the fanatec control panel or on a separate screen somewhere? Cheers

  • Hey guys, from a friend can I ask you if the CSL F1 Elite V1 (the old one) steering wheel is 100% compatible with DD2?

  • Hey, Finally got my DD2 today. Is it normal That you have microvibrations in Wheel? Low torque Mode.

    Its not much But you can slightly feel it when i touch my Wheel and the base is turned on

  • Hi, I have the DD2 from more 2 years and never had vibration when it turned on in idle.

  • Hi lately I have an issue with my DD2, hope somebody can help me.

    I have the DD2, last driver (455) and firmware updated, I am using a formula V2.5 wheel.

    For first time I run endurance races in iRacing this last weeks, I run two races of 160 and 180 minutes, so 3 and almost 3hrs of driving. The issue is aprox after 1.5 or 2hrs (not sure of the exact time, but more than 1.5hrs for sure), suddenly I loose almost all the FFB for just a second, I think I am not loosing all the FFB completly but it decrease a lot, the wheel looses almost all resistance, but as said it is only 1 second, inmediately I got proper FFB again (fortunatelly in both cases I was in a straight and did not crash...). After this "panic" second everything is OK till I end the race. It happened in both long race, not sure of the time stamp but for sure in both cases after more than 1.5hrs. When happened I was not able to check in the base screen, so do not know if there is some message there.

    So now I am not sure at all to try again as this could be a lottery if it happens in a corner and I crash after more than 2hrs of driving.

    Any idea what could happen?, is there a way to check a log or similar to figure out?

  • More info, as I thought maybe was a heat issue, I am playing with the FFB limited to 15Nm in the driver (in iRacing with full 25Nm if you crash the wheel reaction could be not safe at all...), and the ambient temperature in the room is not hot at all lately. I do not know if the issue is the motor of the base protecting itself for temp... but as I said the base is only delivering 60% of its max Nm in a room not hot at all... should not have a temp issue I guess... but never know

  • Hi. First post for me here.

    Tonight when i was updating my Podium F1 DD1 base the power in the house went down.

    And now i cant turn the base on. Fan starts when pressing the power button on the back. but nothing more.

    What do i do to sulve this problem?

    Buy a new base?

    Best Regards Daniel

  • go into the control panel and at the bottom in blue it should give you a link to fixx the wheel base when its bricked like this

  • Yeah. Did find it. But, my problem is that the display dont light up. The only think making a sound of life is the fan when pressning and hold power button at the back.

  • Ugh, update to the latest firmware and now my dd1 is bricked. Getting the Wireless Quick Release error and am out of warranty :(

  • Hello everyone,

    I have the same problem which has been recurring randomly since September/October.

    This happens after 2 hours or 30 minutes, there is no rule.

    I reinstalled the drivers and checked the connections and found nothing.

    In Iracing in replay I noticed that the steering wheel in the cockpit goes crazy during this milisecond/sec.

    I don't know if iracing is aware of this problem but I have already found other people who have exactly the same problems on another discord page since the same dates (September/October).

  • Hi, maybe I'm in the wrong room to ask for info. Does anyone know if Fanatec is planning to release a BMW style steering wheel (the €1400 one)
     but in a version designed for sim racers only? That is, less expensive but with a width of 30 cm, programmable LEDs on the buttons? 
    Maybe a cheaper version (€500/600) of that steering wheel? Fanatec is missing a 30cm wide GT steering wheel. 
    Maybe even with a screen but the LEDs would be enough for me. And then what if a handbrake comes out, maybe a Podium version? That is, 
    something cooler than the current one. A new gearbox wouldn't be bad either. Thank you

  • Hello. 

    The DD1 PS5 randomly shuts down while playing. Sometimes it's five minutes, sometimes after half an hour. What could be the problem. Pc doesn't do it there, it works fine.

  • @attila Toth. See this thread...

    I had a similar problem with my DD1 where it would shut off entirely when it had to respond to a high-torque signal demand. The problem kept getting worse over time and eventually, the DD1 would not even power on. It turned out to be a Power Supply issue. I suspect the the Power Supply was experiencing a degrading failure (unable to provide proper voltage/current - its a switching power supply with variable output driven by a pulse width control signal. I replaced the power supply and my DD1 is back in business.

  • @Patric Blaha "Hey, Finally got my DD2 today. Is it normal That you have microvibrations in Wheel? Low torque Mode.

    Its not much But you can slightly feel it when i touch my Wheel and the base is turned on"

    I experienced the same thing with my DD1 when I updated to the latest PC drivers and wheel base firmware. My game of choice is Assetto Corsa, and with my settings, I can feel what your describing but only when the car is stopped. Ive noticed that for me it also depends where I stop the car on the track and or what is going on around me. (its not consistent).

  • After builded my setup with CSL DD wheel base on PC,the EA WRC has PS5 menu.Any idea?

    My wheel is the CSL P1V2

  • Help! I"m stuck in a firmware update. I have a DD2 with McLaren GT3 V2.

    Main FW: V3.04 HW: V0

    Motor: V42.0.0 HW: V2 ACV: V3

    WQR: FW: v7 HW: v0

    The wheel/base is not recognized by Fanalab or Fanatec control panel; Base fan is blowing at 100%.

    I've struggled with mutiple unstall and reinstalling for several hours today without any positive result.

    Driver ver is 455.

    Fanalab ver is V2.01.21

    Please help!


  • Oh gosh, never mind. It turned out that removing the McLaren GT3 wheel and swapping in my other available wheel, the Porsche 919 Replica triggered the Control panel to another update cycle and that worked.

  • Stuart BrownStuart Brown Member
    edited March 15

    Podium DD2

    My hardware is 3 years old so the quick release is the previous version, not the latest one I see on the website for the DD2.

    Porsche GT3 wheel = Podium Hub, Podium Button Module Endurance, Advanced Paddle Module

    Formula V2 wheel with Advanced Paddle Module

    Driver 455 when issue started, but also tried 450,451,454,456.

    Sim rig PC Windows 11 64bit

    Desktop PC Windows 10 64bit

    I'm posting in this thread because after many hours of troubleshooting I think it may be an issue with the DD2.

    I've been running driver 455 with it's included firmware updates for all my hardware with no problems. A week ago I got in the rig with Porsche wheel attached and as soon as I turned on the DD2 an automatic firmware update for the Podium Hub began without even asking if I wanted to update. The update was reported as successful, but then it went back around to wanting to do the same thing again... and again... and again. Which I did, but clearly something wasn't right, so I rebooted the PC only to find I'm back in the firmware update loop.

    Since then I've spent many hours going over everything I can find in the forum. I've tried drivers 454, 451 and 450 using downloads I know for sure worked from my local drive. Each time manually downgrading the firmware to the one's included in the driver package to make sure there is no mismatch between drivers and firmware. I've since also tried the latest 456 driver.

    I found that if I did the long press power on to do a base firmware update it would recognise the wheel... temporarily. If I switch off and back on the DD2 its random whether it recognises the wheel or not. Sometimes updating the Hub firmware, then restarting the DD2 and/or Control UI can help, sometimes it doesn't. There is no obvious repeatable pattern for why it works or doesn't.

    I've swapped back and forth between the Porsche and Formula V2 wheels as I've tried each driver and corresponding firmware combinations. When I do finally get a wheel to be recognised and firmware shows as being up to date, I get the same problem on both wheels because the upshift paddle on the APMs is not working on either wheel. This happens with all driver/firmware versions I've tried.

    I even removed the APM from the Formula V2 wheel to put the original basic paddles back on, but it's the same story, no upshift paddle working. At least I know it's unlikely to be an issue with a physical paddle switch.

    The pins on both wheels' quick release are all straight, clean and undamaged. I loosened and retightened the hex nuts around the pins on both.

    I use the original USB cable plugged directly into the motherboard and have tried every motherboard USB socket. Also tried another known working cable, but it made no difference, however at least it eliminated that as a possible cause. I've also tried doing the firmware updates on my Windows 10 64bit desktop PC and get the same issues.

    It seems to me there's possibly 2 distinct issues here, but not being an expert they might both be fixed by working drivers/firmware. Either that or there's a hardware issue with my DD2.

    1. The DD2 is not recognising that the firmware is already on the wheels as it shows firmware version 0 for both wheels when it wants to do the updates that end up in a loop.

    2. There is an issue in the DD2 with a connection to the upshift paddle.

    Any suggestions or help from anybody before I open a support ticket would be greatly appreciated as I've tested everything I can find on the forums so far. Thank you.

  • The WQR Module of your base of broken. Contact the support.

  • Hi having massive trouble getting my DD2 working again. I think it did an update which now says ping error when trying to install the firmware. I have tried rolling back driver and firmware and I do get the unit to stay turned on now but it just sits there with fan going at 100%. I suspect wheel motor firmware needs updating as it says ver 0 but I do not know how. When I go through the config software to install only wheel motor firmware upgrade the application just closes. I have read that others have had this problem and have tried all the things which have been suggested but none work.

    I also cant put in a support ticket because the display screen on the unit will not operate with either steering wheel mounted so I cant get to the serial number and so I cant progress any support. Is the serial number on the hardware anywhere as I cant see it?

    How do I just upgrade the wheel motor firmware?

  • On the DD2, the serial number is under the top cover.

    DD1 & DD2 have removable side and top covers held on by magnets.

    Sounds like your base is bricked. If all the "fixes" have not allowed you to recover, you will need to RMA the base for repair.

  • Hi yeah found it and put in a request for support. But how long will they take to come back to me and how long should RMA take? I am desperate to get the unit working again.

  • You are going to wait a few weeks for a reply to your support ticket.

    I would also have pics and detailed description of issue and remedies you have tried ready because that is the first thing they are going to ask for when they do replay to your support ticket.

    You are most likely looking at a month or two for RMA after they issue one to you.

  • For anyone in the US with the WQR error, just got my quote from Fanatec for an out-of-warranty Podium DD1. Fanatec received it on 1/26 and just got the quote today 4/8. Wasn't as bad as I thought it would be.

    Service Fee: $63

    WQR PCBA: $44.32

    Shipping everything back: $15

Sign In or Register to comment.