Fanatec Driver 451 (Prev. Official Release) for CSL, CSW and Podium WB (all wheels)



  • Hello

    GT DD Pro Base.

    When trying to click update, so the wheel base motor firmware can get upgraded. Firmware updater opens, and shows " Power of the wheel "

    Cant really find out what is going wrong, is there any known bugg on GT DD Pro base about this?

    I also had issues in the 450 driver. In the old 447 driver everything worked as expected.

    Can anyone help out, or should i just wait for further drivers / firmware updates?

  • update for info.

    Formula v2.5 wheel was connected. Update firmware didnt work. Without wheel didnt work.

    But when i plugged in the csl wheel i have, then everything worked.

    • Natural friction can start to feel weird after some time of driving. In case you experience issues with NFR, we suggest to turn it OFF for now. (this got now fixed for the Podium DD but can still happen on the CSL DD. We will now apply the fix for the CSL DD as well)

    Is this the same problem as the grainy/scratchy ffb that the test firmware 20khz/18khz fixes? I just wanted to make sure that it's still being worked on and I won't be stuck using an old firmware forever.

  • edited August 2023

    No, that's a different issue.

    The scratchy FFB was a hardware issue on some units which will not be fixed via Firmware.

    So actually, you would need to contact the support to get your base repaired or exchanged if you have the issue as it's not going to be fixed via Firmware in the future.

  • Fix the drivers from your last update.
    With previous drivers on my base dd2 there is no ffb graining or anything, everything worked perfectly.
    Fix the drivers.

  • I install the previous drivers and everything works perfectly.
    But when I update my three wheels and not being able to reinstall them from the previous version they don't work correctly and I have to reinstall the crap from the last update.

  • Please explain in more detail whats wrong, and maybe in a slightly nicer tone, then you might get help.

  • I've created a thread so we can share information about miss shift problems - feel free to share your problem there. Maybe we'll find solution one day.

  • Hello i have problems with my podium DD1 F1 steering wheel PS4/5 to connect to my PS 5.



  • edited August 2023


    First question: Did you uninstalled your current driver, re-downloaded the driver from, re-installed that freshly new downloaded driver and tried it again?

    If its still crashing with that driver then you are the only person in the world where it is crashing and in order to investigate whats wrong with your pc you need to provide the Windows Event Logs of the crash. Open the Windows Event Viewer -> Windows-Protocols -> Application. Select every red exclamation mark which includes "FanatecControlPanel.exe" and save them as evtx files and upload them here as a zip package.

  • Hello! Yes i tried to Uninstall etc i also reset my pc in the time..

  • edited August 2023

    Looks like your registry is f*cked up for whatever reason, most likely a Windows issue and not really a driver issue.

    However, even though it appears to be unlikely a driver but more a Windows issue, you can still try the following:

    1. copy-paste %LOCALAPPDATA%\Endor_AG_Fanatec in the File Explorer and press enter,
    2. copy and zip all the content of that folder and upload here,
    3. close Control Panel UI,
    4. delete all the content of %LOCALAPPDATA%\Endor_AG_Fanatec,
    5. restart Control Panel UI
  • Hey TY for the good information but it could not find the folder, i was in Localappdata, there was no folder like this and the fanatec folder was empty

  • edited August 2023

    That's very weird.

    Looks like your complete Windows is messed up..

    To be 100% sure, what's the exact Name of the driver folder you try to install?

    Is it 2023.05.16-Fanatec_driver_451 or 2023.05.18-Fanatec_driver_451?

    Also please list all your hardware, so base, pedal, wheel, etc and how you have it all connected.

  • The name of the driver folder is 2023-05-18...451

    My Hardware is Fanatec CSL Elite Wheelbase with CSL Wheel, and Fanatec V3 Pedals. I have connected it but also tried to unplug it an plugged in and plugged in and connected.

  • When is the known friction issue for the CSL DD Pro and GT DD Pro going to be fixed? I feel like it's been a year or more since it's been known and it's still not fixed. Is it planned with a date already? I think it's a major issue and should have more priority.

    The wheel is an entry point into the Fanatic brand name and it's going to get a bad reputation if after an hour, it starts to feel like it's breaking and I have to stop playing or just deal with it. Of course the Podium DD got the fix first because it's more expensive, but how are people going to want to buy that version if their first experience is this issue?

  • edited August 2023

    I think you mean a different issue than the known issue caused by NFR.

    When you get a friction / cogging feeling after an hour (so when the base got warm) then this is a hardware and not a firmware issue. So, this means, there wont be a firmware fix for this kind of issue.

    FOr the other NFR related issue there is no ETA for a fix yet but it's still high on the Prio list to be fixed in the future.

    In the meantime it's still recommended to not use NFR but to compensate with NDP / NIN.

  • I just saw Travis Nordstrom's post here about a scratchy FFB. That is the same issue I have. I thought it was because of NFR. The GT DD Pro only has a one year warranty right? If I would've known this, I would've requested it sooner.

  • edited August 2023

    I'm in the US. Oh no... maybe an exception can be made in this case. I never got a notice of a recall. This sounds like it should have been a recall. Imagine all the people who have it and don't know about it and think it's just a bad product.

  • Same, I'm also in the US and my warranty is out. In case it's denied, did you at least get a hold of the test firmware?

    "GT_DD_EBLDC_V1_0_2_3_testExport_20_kHz_app_S.hex" fixes the issue for me. The only reason I didn't press the issue during my original RMA was that I was assured in the email correspondence that the fixes were going to be implemented into a future firmware update. Now, knowing that I'm going to be stuck running that old experimental firmware forever doesn't make me feel very good. If I can't get an RMA now, I'll be really disappointed.

  • Ohh, I also thought that the scratchy/grainy feel after a longer period is the NFR issue, so I should probably create a support ticket, but tbh I got the issue frequently in the spring but not anymore, strange.....

  • Hello,

    Just tried to update my wheel after facing FFB loss while driving, with no reason.

    Now the wheel is not even detected by the computer, also the recommendation made on the dedicated pdf says to put back version 442 but it's not available anymore !

    I spent the last two hours trying to fix. Came back on all the driver versions I had (429), still, never recognised, can't see it connected - followed all instructions but yeah, as said, there's no 42 version anymore.

    When going back on the old version, the fan is off, but the buttons are not working anymore (lol...)

    Thanks for a quick action/answer , I have SRO Endurance series next week on ACC...

  • Hi, apologies for replying to old message but maybe this will be of any help or not, I am also dealing with werid behaviour of funky switch after upgrade to 451 on one of my wheels: the Porsche 918 (I think it was the last batch or one of the last) on DD1 - PS4 version (bought November 2022). With the included Formula 2.5 no such issue is present. I was suspecting the firmware might be an issue as it was never a problem up until the upgrade, going to downgrade to 447 for now probably so thanks for the tip.

    I also had one weird issue just after upgrading to 451 - all buttons on Formula suddenly stopped working (and lights + screen on the wheel froze) once during driving session in ACC but I did not lose FFB from what I remember, I wanted to untight, unplug and plug the wheel, however I left it sit for a while and it unfroze after a period of between 30 seconds and 1 minute. I'm not sure whether that could be my mistake - possibly not tightening the wheel enough, or maybe it just didn't 'seat' in properly, or something else. That was my first case of this happening, it did not happen again since so far.

  • Since Mateusz posted something similar I kindly note I am also affected with incorrect funky switch behaviour. It cannot be a hardware issue since each and single click works fine in the tuning menu of the endurance module as well as in the FCP. It's only Windows that doesn't register inputs properly. Also I believe Hub CS UHX V2 + PBME is not to be called a Legacy wheel yet? It looks to me like Windows is ignoring too short inputs and registering only these longer than xxx ms.

  • Hi, I just got my new CSL DD, and found a small bug not frequent, and actually not exactly like the wheel disconnect issue.

    When driving, randomly fter 30-40minutes the inputs (pedal and wheel) is fixed for a second, and then everything works fine. no disconnect sound, and the shaft is double checked, in place.

    Here is an example video:

    I found this bugfix note from driver 450: Improved steering input jump issue so the issue happens a lot less than before. Full fix expected for one of the next versions.

    Maybe this bug is what I have, and should wait until fixed? If the shaft would be the failed part, the discconnect time should be longer, is'nt it?

  • An exception was not made so far in my talks with support right now since the warranty for US products is only one year. That doesn't make any sense why Europe has an extra year of warranty. This is a known hardware issue that I just found out here in the forum and I'm expected to pay for repairs? That is a terrible customer experience. I thought the NFR issue as I mentioned earlier was the issue that I was experiencing and I was just waiting for the fix and I feel like I was tricked into letting my warranty expire. I wonder how many other customers are in the same shoes as me and the other customer who had the same issue in this thread.

  • Hello, I recently bought the DD2 and clubsport formula v2.5 rim and after the driver installation, the fanatec control panel instructs me to update the firmware. I followed the steps to update the firmware and when it has been updated and the wheelbase has restarted, the display on my dd2 goes blank, and this screen pops up :

    When this screen pops up, I re-opened the control panel but it says :

    I have read the troublshooting guide in the maunal included with the driver download but I cant seem to find anything.

    Does anyone know of a fix or other things to try?

    Thanks in advance

  • And happened again and again. just for half second, the inputs were freezed, then go again.

    What can be this? I removed the shaft, checked the assembly, then carefully tension the fixing screw. replace the QR lite the QR1, and still happen.

This discussion has been closed.