Fanatec Driver 451 (Prev. Official Release) for CSL, CSW and Podium WB (all wheels)

Marcel PfisterMarcel Pfister Member, Administrator

How to report issues:

If you report a driver or firmware issue, please make cross checks:

  1. Update driver and FW separately to isolate an issue and find out if caused by driver OR firmware.
  2. Which driver OR firmware shows the issue
  3. Which driver OR firmware does not show the issue
  4. Check if you can reproduce the issue again if you go back to the version which seems to have caused the issue
  5. Check if the issue is related to specific settings of for example the tuning menu. Is it happening more or less with a specific setting raised or lowered?
  6. Post the answers gathered from the questions above + a short description of the issue including the following info:
  • Wheel Base Model (product ID): ...
  • Steering Wheel Model (product ID): ....
  • Driver Version: ....
  • Base FW Version: ....
  • Motor FW Version: ....
  • Wheel FW Version: ....
  • FanaLab Version: ....
  • Tuning Menu settings
  • Driver/FanaLab installed on C: drive or else?
  • With driver related issues collect log files and zip them from C:\Users\Public\Fanatec Logs

Changelog of driver 451 (since 450)

Firmware versions included

  • Podium DD1 / DD2 Base:
  • Podium DD1 / DD2 Motor:
  • CSL DD / GT DD PRO Base:
  • CSL DD / GT DD PRO Motor:
  • CSW V1 Base: 692
  • CSW V2 Base: 692
  • CSW V2.5 Base: 692
  • CSL E Base: 692
  • CSL E Base PS4: 692
  • CSL / CSW Motor: 22
  • Podium BMW M4 GT3: 8
  • Podium HUB: 6
  • Podium BME: 22 
  • CS SW Formula V2(X), V2.5(X): 46 
  • CS SW RS: 4 
  • CS SW BMW V2: 3 
  • CS UH V2 / UHX V2: 2 
  • CS SW F1 Esports V2: 5 
  • GT DD PRO SW: 8
  • CSL SW McLaren GT3 V2: 46 
  • CSL SW McLaren GT3: 36 
  • CSL SW WRC: 4
  • CSL UH: 8 
  • CS P V3: 1.35
  • CSL EP V2: 1.6
  • CSL EP LCK: 1.13
  • CSL P LCK: 1.8
  • USB Adapter Handbrake mode: 1.10 (NEW)

Control Panel

  • Fixed UI freeze/crash with pedals connected and when going to the pedals page.
  • Fixed issue of incorrect steering angle shown (-1080°) when opening the driver with wheel turned completely to the left.
  • UI now shows current maximum torque in Nm depending on the FFB strength settings set in the Tuning Menu. On the Podium DD it's also dependent on the connected wheel and the torque key, therefore the torque value is only shown with a steering wheel connected.
  • Wheel Base page is now always shown for easier access to trouble shooting tips if needed which was more difficult to find when other devices were still connected.
  • Included additional hint info for Standard/Advanced Tuning Menu toggle to explain that Setup 1 will be reset when going back to Standard mode.
  • Increased the timer to show hint texts until mouse is moved away.
  • Other minor improvements.

USB Adapter Handbrake Mode

  • Added manual min/max calibration for the handbrake connected to the USB Adapter. Firmware update of USB Adapter required.

Tray App (optional installation)

Latest version of FanatecApp on Android/iOS required as well, more info about the app on:

  • Fixed Tray App icon not shown in the Tray since Windows 11 "Moment 2" update.
  • Fixed several issues with the SEN slider, including a crash which could happen while switching between Standard and Advanced Tuning Menu mode.
  • Fixed default values resetting to wrong values while switching between Standard and Advanced Tuning Menu mode.
  • Fixed an issue where only Green FlagLEDs were working in the Dashboard, now all FlagLED colors are working.
  • Fixed non-working ACP radio buttons. Now the radio button is reflecting the actual status of the chosen ACP setting and it's now also possible to change the ACP setting in the App which previously had no effect at all.
  • Now possible to switch between Standard and Advanced Tuning Menu through Mobile App.
  • Now possible to reset Tuning Menu settings through Mobile App.

Known Issues

  • If you had issues with the Control Panel UI crashing: Re-download the driver below (it got updated) -> uninstall the current version -> Install the new driver 451.
  • When entering a game menu while driving it can happen in some games that the FFB effect doesn't get canceled which results in the wheel turning to one side. (this got now fixed for the Podium DD but can still happen on the CSL DD. We will now apply the fix for the CSL DD as well)
  • Natural friction can start to feel weird after some time of driving. In case you experience issues with NFR, we suggest to turn it OFF for now. (this got now fixed for the Podium DD but can still happen on the CSL DD. We will now apply the fix for the CSL DD as well)
  • The steering input jump issue was greatly improved so the issue happens a lot less than before. Full fix expected for one of the next versions.

Compatible FanaLab Version




  • very little change considering that the v450 came out 3 months ago.... too much work with future peripherals? XD 

  • Gunthar RoweGunthar Rowe Member
    edited May 2023

    Drivers installed and wheel, base, and pedals show in Fanalab but Fanatec Control Panel does not open when you double click on the desktop shortcut.

    This is being installed on a new build PC

  • edited May 2023

    Everything good, less the phone app. Can't connect since Windows 11 "Moment 2" update, and still not able to connect with this driver !

    We always have simhubdash, but this is much more practical.

  • Please explain a bit more in details what your iissue is.

    With this new Tray App included in todays new driver 451 all iissues with Windows 11 Moment 2 are fixed, the Tray App icon is visible again in the Tray App and should connect fine to the Mobile App, when you have set your Firewall settings properly.

  • Hi Maurice, first I installed the driver on top of the old one. The app driver worked, but the tray, phone app didn't. Then I tryed a complete uninstall of both driver, and fanalab ( I know they are not correlated in this case).

    I reinstall the driver, and after complete but before restart, the tray is working, the driver app isn't.

    After restarting it doesn't work, neither the driver app, nor the tray, phone app. But the driver is working fine, along with fanalab. Also, my Windows installation is only a month old and healthy ;)

    Also my firewall is open for the tray.

  • Please show some Screenshots of what you mean as I have absolutely no idea what exactly your issue is. For me (and every internal Tester) everything is working fine, so dont know what's the issue is on your end.

  • Mauruce,

    like already reported, in this case fresh install of windows control panel won't open.

  • @Maurice, how do you call the interface of the fanatec driver ? App ? Fanatec Driver Control Panel ? That and the Tray don't work even after a clean reinstall of the driver.

    The Driver work, Windows connect to the Base.

    And I'm not the only one, we already had Hugo before me.

    I cant give you screenshots of a App ? Fanatec Driver Control Panel ? that dosen't open, so I can only show you my desktop :)

    Also I'm on Windows 11 and work on IT.

  • edited May 2023

    These are the "official" names:

    Fanatec Control Panel (also called Driver UI) is the Driver.

    Tray App is the Windows Tray application.

    Mobile App is the corresponding Mobile App version.

    Unfortunately I can not help you without a bit more Information what exactly is not working at which moment and Marcel is not available until early June.

    Whiich pedals do you use? Have you tried to disconnect the pedals and try to open the Control Panel to then be able to generate Logs?

  • Maurice, the problem is with driver UI, simply doesn't open, neither by desktop shortcut, tray app shortcut, or found directly to the EXE. Driver is working in the background cause fanalab identifies the hardware, but the UI doesn't open.

  • edited May 2023

    Everyone with the Control Panel crashing when trying to open it:

    • copy-paste %LOCALAPPDATA%\Endor_AG_Fanatec in the File Explorer and press enter like this:
    • Copy and zip all the content of that folder and upload here (or send me via PM).
    • Close Control Panel UI
    • Delete all the content of %LOCALAPPDATA%\Endor_AG_Fanatec
    • Pedals connected via RJ12, try opening Control Panel UI if it still crashes.

  • i dont have that folder...

  • edited May 2023

    Alternative: C:\User\YOUR_USERNAME\AppData\Local\Endor_AG_Fanatec

    Thats a folder you HAVE TO have, otherwise the driver is not properly installed.

    If you do not have the AppData folder, then you first need to unhide hidden folders in Windows.

    For W10: open File Explorer, select "View" > "Options" > "Change folder and search options" and then select the "View" tab and, in "Advanced settings", select "Show hidden files, folders and drives" and click "OK".

    For W11: open File Explorer, click "Layout and view options" (the second menu from the right), select "Show" and check the "Hidden items" option.

  • it doesn't create it, i'm on 64bit, already installed twice, and it doesn't create that folder, like i said, this is a fresh install, i', finishing it now to create a disk image...

  • @Maurice, ok no problem.

    The driver work, but the Driver UI and the Windows Tray application don't.

    Even if I try to run the Driver UI as Administrator, it wont start .

    I have the old driver with a working driver UI, but I only use it for firmware updates.

    I set everthing on fanalab, with you profiles and a few minor tweaks of mine.

    I'll wait for future updates, the only thing that wasn't and still isn't working is the Windows tray, so no connection to the phone.

    No worries, that is just and extra that Fanatec decided to offer.

  • But you had some older driver installed on your Windows before which worked well? THen the folder has to exist - miine for example is dated from 23rd June 2022 when I installed the first driver on my new Windows install. It wont be created new by a new driver, it only will be created initially by the first driver.

    When your Windows installation is brand new and this is your first driver, then uninstall 451, install 450 and try with this driver to generate the folder.

  • Did you tried what I suggested?

    To disconnect the pedals and try to open the UI?

    And to delete the Endor_AG_Fanatec folder in AppData (with a previous save and upload here)?

  • Maurice,

    Short story, this is a ne platform, so fresh windows install, the first driver i tried to install was 451, this driver doesn't create the folder you specified, even if i create the folder manually, it won't help, what worked was to install 450, this one creates the folder, uninstall and install 451, this way works. if i delete contents of the folder, the driver doesn't have the ability to recreate them...

  • THAT'S interesting.

    So now the Control Panel is opening for you also with Driver 451 after you first had 450 installed?

  • yes, but like i said if you delete the contents of the folder it doesn't open anymore, for me there's something missing in the driver code to create this folder/files... 64bit version.

  • Yes that's actually a good hint that this very important folder does not get created with this driver and therefore this driver only works when you had at least one older driver installed which had the folder created.

  • also, how do you start the tray app manually?

  • yes you can, if you go to directlly to EXE in program files folder, but there should be a shortcut, either created by install on desktop or something like that or a shortcut in driver UI

  • edited May 2023

    There is no shortcut.

    The Tray App is intended to exclusively start with windows and can otherwise only be manually started by double-clicking the FanatecApp.exe in the driver installation folder. But this manual start should never be needed (in an ideal world at least) as the Tray App should "just work".

  • Ok, so we need to install the new beta driver without uninstall the old driver, or install the old first, because the new one doesn't write the Endor_AG_Fanatec folder.

    After that create a shortcut of the FanatecApp.exe, because the Tray App don't start with Windows, at least for me.

    In the end it's all working, not as it should, but working nonetheless.

    Let's wait for the next beta, and call it a day.

  • For me the tray app is working ok... If you haven't installed a prior version to this one, install 450, uninstall, and than install 451

  • I'll skip this mess. I'll wait until there is a proper, fully tested release.

  • edited May 2023

    It was fully tested and nobody internally ever had this kind of issue because nobody tested on a completely fresh Windows install.

    Such issues can only be found with this public beta releases.

    If you dont have a fresh Windows install then you also wont have this "mess".

  • If nobody tested on a fresh install then it was not fully tested and the testing regime is flawed.

    The evidence for this is that within hours of being made public, the users above found the issues that were missed in official testing.

    Any decent pre-release testing would cover typical use cases - which you should have already known, and now certainly do, include fresh installs.

    BTW - internal testing will never get better if you and your colleagues can't accept that mistakes are made. Think of them as learning opportunities. :)

This discussion has been closed.